It's not unusual for many users to use weak passwords simply because they're less difficult to remember or to use scripts, templates and plug-ins that are not updated for a long period of time. In either of these examples, it will not be a challenge for a hacker to take over the site and from there on to take control of other websites which are hosted within the very same account. To avoid this kind of a scenario, we have added an advanced level security option known as JailHost. It restricts the access which a script has just to its own folder, so in the event that one of your sites is compromised, the attacker will see its content, but won't be able to access any other content within your account, thus the damage will be minimal. Needless to say, using JailHost will not substitute the security measures you should take by keeping your scripts up-to-date and using long and complex passwords, but it will allow you to limit the damage to one site only.